• 0
explo4x4

Problème de vol ZYX-M

Question

Bonsoir à toutes et tous,

J'ai un soucis de vol sur mon contrôleur ZYX-M. Lors de la mise des gaz en mode ATTI ou GPS, le drone ne conserve pas son assiette et tente délibérément de partir sur sa droite jusqu'au crash ! J'ai pu tester quelques secondes le mode MANUEL qu a l'air correct.

Ma config est la suivante :

Montage X4, sens hélices ok, 4 moteurs DYS 2300kV, Lipo 3s, 4 x ESC BLHELI 16A, contrôleur ZYX-M, radio TARANIS X9d Plus, et récepteur FrSky 8DR. La config via l'assistant a l'air ok : récepteur en S-BUS, ESC calibrés via BLHELI suite, étalonage des sticks radio, modes de vols ok (MANUEL/ATTI et GPS), calibrages Accéléromètre et Gyroscope OK. PID modifiés à plusieurs reprises ans amélioration notable (valeur du manuel par défaut aujourd'hui). Etalonnage avant décollage OK.

Le problème survient en mode ATTI ou GPS, clairement le drone refuse une mise en stabilité à la mise des gaz et part violemment d'un côté ou d'un autre....?!?

Ca fait un moment que je suis dessus sans succès !

J'en appel à un expert !!!! :-) Merci pour votre aide.

Manu

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Bonjour,

Même problème pour mon père et moi. Mode Atti ou GPS, le drone a des sursauts incontrôlables, et en plus il ne nous laisse pas pleinement la main sur les gaz. Mais en manuel, impossible de stabiliser l'engin, beaucoup trop réactif ! Nous faisons nos tests en arrimant le drone (avec un peu de "mou" pour qu'il puisse s'exprimer mais pas se retourner !!) sinon on aurait déjà cassé une dizaine de jeux d'hélices...

Il s'agit d'un X6, télécommande DEVO 12E, récepteur DEVO rx1202 en conventionnel. Contrôleur ZYX-M.

Si une bonne âme bien informée pouvait nous aider, ce ne serait pas de refus !

Share this post


Link to post
Share on other sites
  • 0
Guest Manu

Bonsoir tapache,

Après une lutte acharnée, le problème a été résolu... en cause les PID ! Les réglages de base étant très éloignés, il a fallu tester, chercher, retester, rechercher, bref j'y suis finalement arrivé. Chaque cas étant différent, difficile voire inutile de te donner une quelconque valeur pour chaque axe, mais ne désespère pas, moi j'étais à deux doigts de tout laisser tomber. Bref, aujourdh'ui la stabilisation est réellement parfaite en mode GPS, ça vaut vraiment le coup de s'acharner !!! Bon voilà, un petit coup de boost ça fait du bien au moral, moi j'étais au plus bas :-)!!!

PS : pour info, j'avais essayé avec un X8 coaxial, IMPOSSIBLE !!! mais j'y reviendrai connaissant maintenant la source du problème.

Manu

Share this post


Link to post
Share on other sites
  • 0

Bonsoir et merci pour cette lueur d'espoir ! Après quelques tests cet après-midi, on entrevoit une amélioration ! Nous allons encore devoir tâtonner par-ci par-là mais nous savons enfin où chercher ! Encore merci ! =)

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
    • 2 Posts
    • 188 Views
    • 2 Posts
    • 522 Views
    • 3 Posts
    • 322 Views
    • 5 Posts
    • 873 Views
    • 2 Posts
    • 410 Views